Google Pay Top Up Payment Method Temporarily Disabled for US NY customers

Incident Report for OG Status Page

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 02:54 UTC

Update

We are continuing to investigate this issue.
Posted Jul 24, 2026 - 23:43 UTC

Investigating

Investigating - Google Pay Topup Payment Method has been temporarily disabled for US NY customers.

Please use alternative payment methods below for time being:

- Apple Pay
- Debit Card Top up
- ACH Pull Deposit

Sorry for any inconveniences caused.
Posted Jul 24, 2026 - 22:52 UTC